Talon Game

Refractory Studios

You are not logged in.

Announcement

Version 1.2 released; new game mode, new map, misc improvements

#17 2014-01-01 19:30:59

CDN_Merlin
Beta Tester
Registered: 2013-09-25
Posts: 75

Re: Couple of issues in V 1.0

So I set the fire missiles to my stick and to the delete key since it was set to mouse axis.  It now stops firing. 

Good to go now.

Offline

#18 2014-01-01 19:47:07

CommandoRash
Member
From: Clarksville, TN
Registered: 2013-11-12
Posts: 96

Re: Couple of issues in V 1.0

Do you have any kind of controller software running in the background like JoyToKey?

Offline

#19 2014-01-01 20:10:04

CDN_Merlin
Beta Tester
Registered: 2013-09-25
Posts: 75

Re: Couple of issues in V 1.0

I have nothing in the background running

Last edited by CDN_Merlin (2014-01-01 21:25:15)

Offline

#20 2014-01-01 21:16:56

Scott
Refractory Studios
Registered: 2012-08-07
Posts: 454
Website

Re: Couple of issues in V 1.0

Mouse axis? Very weird, but that explains it. I guess I had better check that default config file!

BTW you can un-map a command by re-mapping it and pressing Escape when prompted for a key.

edit: Huh. Default config file looks correct, so I'm not sure how that happened.

Last edited by Scott (2014-01-01 21:23:02)

Offline

#21 2014-01-01 21:29:14

CDN_Merlin
Beta Tester
Registered: 2013-09-25
Posts: 75

Re: Couple of issues in V 1.0

Yes, I was able to unbind it hitting ESC.  Thanks I hadn't thought of that.

Offline

#22 2014-01-01 23:12:32

VEX-Munk
Beta Tester
Registered: 2013-10-13
Posts: 45

Re: Couple of issues in V 1.0

Scott wrote:

Mouse axis? Very weird, but that explains it. I guess I had better check that default config file!
[...]
edit: Huh. Default config file looks correct, so I'm not sure how that happened.


The mouse axis gets accidentally mapped to some action quite easily (and often): whenever you try to map some key to an action and move the mouse a tiny bit, it grabs the corresponding mouse axis.

Offline

#23 2014-01-01 23:16:54

Scott
Refractory Studios
Registered: 2012-08-07
Posts: 454
Website

Re: Couple of issues in V 1.0

Ah yes, there is that! I was meaning to increase the threshold for detection of mouse axis binding so that one has to move the mouse farther in order to trigger that. I can't remember if I actually did that or not.

Offline

Board footer

Powered by FluxBB 1.5.9